Google impedirá con Android 14 que puedas instalar apps antiguas en tu móvil

El sistema operativo Android lleva con nosotros más de una década y este da vida a miles de dispositivos, principalmente smartphones. Es la principal competencia del sistema operativo iOS de Apple en el mercado móvil y si bien por el momento seguimos con Android 13, se espera que pronto llegue Android 14. Ahora sabemos que Google pretende realizar cambios significativos con Android 14 y uno de estos implicaría bloquear la instalación de apps antiguas.

Desde hace unos años, Google está realizando cambios en Android que puede que no gusten a los usuarios. La compañía decidió que a partir de Android 10 subiría los requisitos mínimos, reduciendo así los terminales de gama baja que puedan usarlo. Aunque en el lanzamiento de Android 11 en 2020 el requisito mínimo de RAM era de 1 GB, con Android 13 se incrementó hasta los 2 GB. Está claro que el enfoque de Google es ir hacia delante y dejar el hardware antiguo o de gama baja detrás. Pero ahora vemos que también pretende abandonar el software viejo con el futuro sistema operativo Android 14.

Google impedirá la instalación de apps antiguas en Android 14

Android 14 Móvil

Una de las principales ventajas de Android es que es posible utilizarlo en dispositivos de cualquier gama de precios. Y es que, el sistema operativo funciona sin problemas en móviles de gama muy baja, aunque en estos casos hay que realizar sacrificios. En concreto, hablamos de emplear versiones de Android antiguas, ya que estas piden requisitos mucho más bajos que los actuales. Si bien no sabemos que requisitos mínimos pedirá la siguiente versión de Android, lo que si se advierte es que no será amigable con apps antiguas. Se ha descubierto que Android 14 empezará a bloquear las aplicaciones que utilicen versiones anteriores de Android.

Visto así, esto supone un gran problema, pues hablamos de que las aplicaciones a emplear deberán estar actualizadas a la última versión del SO. En el caso de que los desarrolladores no lo cumplan, aquellos usuarios con Android 14 no serán capaces de instalarlas en sus dispositivos. Esto es un enfoque que Google ya ha impuesto a la tienda Play Store, donde exige que las nuevas aplicaciones estén sean diseñadas en mente con Android 12 como mínimo.

Google implementa el cambio en Android 14 para evitar el malware

Android 6 Marshmallow Virus

La decisión de bloquear la instalación de aplicaciones antiguas en Android 14 es debido a que Google quiere asegurarse que proliferación de malware se mantenga al mínimo. Evitando que instalemos las aplicaciones que fueron desarrollados para versiones antiguas de Android, evitará brechas de seguridad y vulnerabilidades relacionadas con estas. Visto así tiene sentido centrarse únicamente en las aplicaciones más modernas y asegurarse de que estas están actualizadas para poder instalarlas en smartphones con Android 14.

Además, también se indica a partir de qué versión serán compatibles las aplicaciones y al final si que hay bastante margen. Y es que, Google pretende bloquear las aplicaciones que funcionan en versiones anteriores a Android 6.0 (Marshmallow). Por lo tanto, tendremos muchos apps disponibles, dado que este sistema operativo se lanzó en 2015. Eso sí, este será solo el principio, pues según pase el tiempo Google pretende aumentar este umbral e incluso permitir a los fabricantes que ellos decidan el límite.